您的当前位置:首页正文

2022-5-16 树的叶子节点个数

2024-11-10 来源:个人技术集锦

树的深度

题目

输入

第一行:1个数n(1 < n <= 1000),表示树的节点数量。 后面n-1行:每行2个数x y,表示节点x是节点y的父节点(1 <= x, y <= n)。

输出

输出1个数,表示这棵树有多少个叶子节点。

输入样例

5
1 2
1 3
2 4
4 5

输出样例

2

代码

#include<bits/stdc++.h>

#define N 1005
using namespace std;

struct Node {
    vector<Node *> children;
};

Node *nodeList[N]{nullptr};

int main() {
    int n;
    cin >> n;
    nodeList[1] = new Node;
    for (int i = 2, parent, child; i <= n; i++) {
        cin >> parent >> child;
        if (!nodeList[child]) nodeList[child] = new Node;
        nodeList[parent]->children.push_back(nodeList[child]);
    }
    queue<Node *> que;
    que.push(nodeList[1]);
    int result = 0;
    while (!que.empty()) {
        auto cur = que.front();
        que.pop();
        if (cur->children.empty()) result++;
        for (auto &i : cur->children) que.push(i);
    }
    cout << result;
    return 0;
}

显示全文