您的当前位置:首页正文

【日期问题】九度OJ 1043:Day of week

2024-11-24 来源:个人技术集锦

一、题目内容

题目描述:

We now use the Gregorian style of dating in Russia. 
The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400. For example, years 2004, 2180 and 2400 are leap. 
Years 2004, 2181 and 2300 are not leap. 
Your task is to write a program which will compute the day of week
corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入:

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). 
The month name is the corresponding English name starting from the capital  letter.

输出:

Output a single line with the English name of the day of week corresponding to the date,starting from the capital letter. 
All other letters must be in lower case.

样例输入:

9 October 2001 
14 October 2001

样例输出:

Tuesday
Sunday

提示:

Month and Week name in Input/Output:
January, February, March, April, May, June, July, August, September, October,November, December
Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday

二、代码及注释

#include<stdio.h>
#include<string.h>
#define ISYEAP(x) ((x%100!=0 && x%4==0) || x%400==0) ?1:0
using namespace std;
//思想:设定一个源点时间(如0000年1月1日),计算将两个日期的日期距离源点日期的时间差,存入数组中,接着计算差值即可(必要时加绝对值)
int dayofMonth[13][2]{
    0,0,
    31,31,
    28,29,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31
};
struct Date{
    int Year;
    int Month;
    int Day;
    void nextDay(){
        Day++;
        if(Day>dayofMonth[Month][ISYEAP(Year)]){
            Day=1;
            Month++;
            if(Month>12){
            Month=1;
            Year++;
            }
        }
    }
};
int buf[5001][13][32];
char monthName[13][20]={
    " ",
    "January",
    "February",
    "March",
    "April",
    "May",
    "June",
    "July",
    "August",
    "September",
    "October",
    "November",
    "December"
};
char weekName[7][20]={
    "Sunday",
    "Monday",
    "Tuesday",
    "Wednesday",
    "Thursday",
    "Friday",
    "Saturday"
};
int main(){
    Date tmp;
    int cnt=0;//统计该日期到0000年1月1日的天数
    tmp.Year=0;
    tmp.Month=1;
    tmp.Day=1;
    while(tmp.Year!=5001){
        buf[tmp.Year][tmp.Month][tmp.Day]=cnt;
        tmp.nextDay();
        cnt++;
    }
    int y,m,d;
    char s[20];//输入的月名
    while(scanf("%d%s%d",&d,&s,&y)!=EOF){
        for(m=1;m<=12;m++){
            if(strcmp(s,monthName[m])==0){//进行字符串比较
                break;
            }
        }
        int days=buf[y][m][d]-buf[2012][7][16];//已知2012年7月16日为星期一
        days+=1;//星期一,所以days+1,星期几就加几
        printf("%s\n",weekName[(days%7+7)%7]);
    }
}

显示全文