您的当前位置:首页正文

1133 Splitting A Linked List

2024-11-08 来源:个人技术集锦

1133 Splitting A Linked List

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤103). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−105,105], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

总结:这道题目在乙级写过,当时总是有一点没有写出来

代码:

#include <iostream>
using namespace std;

int d[100000],ne[100000];
bool exist[100000];
int main(){
    int addr,n,k;
    scanf("%d%d%d",&addr,&n,&k);
    
    int t;
    for(int i=0;i<n;i++){
        scanf("%d",&t);
        scanf("%d%d",&d[t],&ne[t]);
    }
    int first=addr;
    while(first!=-1){
        exist[first]=true;
        first=ne[first];
    }
    bool flag=false;
    for(int i=addr;i!=-1;i=ne[i]){
        if(exist[i] && d[i]<0){
            if(flag)    printf("%05d\n",i);
            printf("%05d %d ",i,d[i]);
            flag=true;
        }
    }
    for(int i=addr;i!=-1;i=ne[i]){
        if(exist[i] && d[i]>=0 && d[i]<=k){
            if(flag)    printf("%05d\n",i);
            printf("%05d %d ",i,d[i]);
            flag=true;
        }
    }
    for(int i=addr;i!=-1;i=ne[i]){
        if(exist[i] && d[i]>k){
            if(flag)    printf("%05d\n",i);
            printf("%05d %d ",i,d[i]);
            flag=true;
        }
    }
    printf("-1\n");//因为下一个地址是在下一个循环才打印的,所以最后的-1在上一个挑选的循环中不会打印
    return 0;
}
#include <iostream>
#include <vector>
using namespace std;

typedef pair<int,int> PII;
int main(){
    int addr,n,k,t;
    scanf("%d%d%d",&addr,&n,&k);
    vector<vector<PII>> v(3);//存放筛选的结果
    int d[100000],ne[100000];
    
    for(int i=0;i<n;i++){
        scanf("%d",&t);
        scanf("%d%d",&d[t],&ne[t]);
    }
    int first=addr;
    while(first!=-1){
        if(d[first]<0)
            v[0].push_back({first,d[first]});
        else if(d[first]>=0 && d[first]<=k)
            v[1].push_back({first,d[first]});
        else 
            v[2].push_back({first,d[first]});
        first=ne[first];
    }
    first=addr;
    bool flag=false;
    for(int i=0;i<3;i++){
        for(int j=0;j<v[i].size();j++){
            if(flag)    printf("%05d\n",v[i][j].first);
            printf("%05d %d ",v[i][j].first,v[i][j].second);
            flag=true;
        }
    }
    printf("-1\n");
    return 0;
}

好好学习,天天向上!

我要考研!

显示全文